How to fix no sound from YouTube in Google Chrome

Chrome no sound YouTubeI recently had a problem where I could not get any sound to play when I was watching YouTube videos or playing flash games in Google Chrome. Other browsers, like FireFox and Opera worked fine. The cause of this bug comes from the newest flash player, version 11.3. This bug was really annoying because I had tried many solutions, but none had worked until I tried disabling all, but one of the flash player plugins.

I noticed that I had 3 different flash player plugins running in Google Chrome and thought that 1 should be enough. So I decided to disable 2 of the flash player plugins and leave one running and it worked! I had fixed my issue with no sound from Google Chrome when watching YouTube videos.

The Solution

  1. Open a new tab and navigate to chrome://plugins/
  2. At the top right, click on +Details
  3. Scroll down until you see Flash
  4. Disable all the flash player plugins, but the one with the directory MacromedFlashNPSWF32_11_3_300_268.dll
  5. Open a new tab and go to YouTube
  6. Watch a video and you should be able to hear sound
  7. Enjoy
Tired of having to search Google for problems like these and clicking through many links just to find the solution? Then go to http://www.ifixwiki.com/, a community-run website dedicated to providing solutions to problems, issues, and errors that occur in everyday situations from software like Windows 7 to hardware like a bicycle.

99 thoughts on “How to fix no sound from YouTube in Google Chrome

  1. Anonymous

    Thanks, this worked for me.

  2. Anonymous

    Thank you so much!

  3. Anonymous

    You're a legend bro!

  4. Anonymous

    Thank you so much, this really helped me a lot.

  5. Anonymous

    So after all of this I can't seem to clear my browsing history… Anyone else have the same problem? Would it even make sense for this to be the source of that issue?

    (But thanks again, for the sound fix.)

  6. Anonymous

    What a bizarre problem. Google chrome should get out of the browser market

  7. Anonymous

    Like a charm! ;))

    Second time You-Tube had no sound! ~x(

    But before-it was in ALL the browsers–:]and then I had to delete some weird file and it worked. THIS time mute was ONLY in Chrome and your solution worked immediately. Awesome!Thanks!

  8. Anonymous

    recently we put windows 7. This fixed my problem^^ happy-desu!! Thank u πŸ™‚

  9. Anonymous

    thanks!!

  10. Anonymous

    It says (17) on top of my Flash tab. Which means there's 17 files in it?.. but I clicked disable but there's 2 disable buttons?… I click one and the other disables anyway..

    Meh I've tried at least 12 different ways.. computers p%$Β£ me off.. why would a browser randomly do this?.. Google are money hungry sell outs…. I'm not using crappy chrome any more.

  11. Anonymous

    Fixed it…sound disapeared after updating flash…

    Thank you!

  12. Anonymous

    TY MAN! i had to disable the opposite flash plugin 8-}

  13. Anonymous

    henyo!!

  14. Giwrgos

    ty man…really helpful!!!!

    love you.

  15. Moimemme

    Just change sound settings to stereo or 2 speakers.

  16. Anonymous

    THANKSSSSSSSSSSSSSSSSSSSSS !!!!!!!

  17. Anonymous

    THANK YOU VERY MUCH!!!!!(((((: IT WORKED!!!!(((:

  18. Unknown

    Nice one that was really annoying me, I had to disable

    Application23.0.1271.64PepperFlashpepflashplayer.dll

    but it was your post that got me there. Again thank you. πŸ˜€

  19. athena

    still not working for me huhu

  20. Anonymous

    thanks mate!!

  21. Anonymous

    great advices there

    did the trick for me

    thank you

  22. Anonymous

    Really really thanks man. Now i can watch youtube again :)) !

  23. Anonymous

    Hey! All other solutions haven't worked to mine. It definitely works! You're so geneous! – hieonn

  24. Unknown

    thanks!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! πŸ˜›

  25. Anonymous

    Works perfectly, thank you

  26. Yiota

    Thank you! Thank πŸ˜‰

  27. Anonymous

    THANK YOU SO VERY MUCH!

  28. Anonymous

    This did the trick after searching for 2 days. Thanks so much!

  29. Laura

    perfect, thanks

  30. Unknown

    thank you :)) =)

  31. coolwicked

    Worked perfectly, thanks bunches C:

  32. sushil lakra

    It worked πŸ™‚ Thanks a ton

  33. Anonymous

    Thanks

  34. David Escarzaga

    thank you!!!!!!!!!!!!!!

  35. Anonymous

    Thanks. Working for me too.

  36. Anonymous

    ythanks

  37. Anonymous

    Thank you, worked like a charm!

  38. Anonymous

    UGH THIS STILL DOES NOT WORK!!!!! I have tried EVERYTHING!!

  39. Anonymous

    I don't understand, when I disable that and then go to youtube it says I need to upgrade my flash player!

  40. Anonymous

    Thank You Very Much or as in my language says 'Terima Kasih' because you have been very helpful. Bless u

  41. Anonymous

    Thanks a lot it worked.

  42. Anonymous

    IT WORKED!Thanks πŸ™‚

  43. coiso

    ok, it worked but… why the hell did this happen in the first place?

  44. DannyR

    Finally fixed. Thank you so much. Was so annoying…

  45. Gayle

    Thank you so much!

  46. Rengga

    Thank you πŸ˜€

  47. christna

    i was having a problem in chrome on my toshiba laptop where embedded videos had sound until i plugged in my logitech headset, then i would lose sound and the sound would stay gone when i unplugged my headset. the sound continued to work as expected in firefox and ie.

    i followed your instructions and it worked perfectly! i just wanted to add detail so that other googlers can find it. it took me a LOT of searching to get to this page!

  48. Anonymous

    Thankyou, you saved my life.

    No music – No life.

  49. Anonymous

    Thank you!

  50. Magus92

    Thanks!

  51. Unknown

    thank you so much man ! πŸ™‚

  52. Unknown

    thank you ever so much!

  53. James

    Try: Update flash via Firefox or other browser.
    Check shockwave updates/

    Also ensure Stereo in volume mixer and low sample rate.

  54. Anonymous

    Thank you so much!!!! πŸ˜€

  55. Anonymous

    Thanks this fixed mine! πŸ˜€

  56. Annetta

    Thanks so very much!!!

  57. Roars

    THANK YOU! was wondering why media player could play sound but youtube didn't! πŸ™‚

  58. antonis73

    The best, easiest and simplest fix. Thank you!

  59. antonis73

    The best, easiest and simplest fix. Thank you!

  60. Marlon

    I came across this article on a previous search, but didn't read it more carefully till yesterday. Thank you for the excellent tip. Chrome should be smarter and not load multiple versions!

  61. Anonymous

    Thanks a lot man, this frustration is finally gone!

  62. Anonymous

    Thanks a lot buddy.. U save my day πŸ˜€

  63. Anonymous

    Thanks! Now i can hear sounds of videos what are not on my playlist. So i got new problem now, i canΒ΄t hear sounds on any video what is added on my playlist :-/ On firefox they are fine..pff.

  64. Anonymous

    You saved a monitor from my fist today.

  65. Daniel

    awesome. simply works.

  66. Anonymous

    I have tried at least 5 different solution, but this worked. Thanks!

  67. Anonymous

    this still didnt work for me…still cant hear anything!!!wtf

  68. Unknown

    OUTSTANDING!! Your Intel fixed my problem…good look

  69. Jeff Dyck

    Nice! Worked for me. Thanks.

  70. Anonymous

    Thank you so much. I spent 2 hours looking for a solution. My brain is fried.
    After restarting Google Chrome, the plugin re-enables itself.
    Please follow these steps to resolve it permanently.

    http://productforums.google.com/forum/#!topic/chrome/ufkQg9N-L0s

    This solution worked for me. I did all of the following steps in this order.

    1. Open up Google Chrome, go to settings > advanced settings > content settings > under plugins – disable individual plugins > expand details in upper right > DISABLE shockwave flash with this location only C:Program Files (x86)GoogleChromeApplication24.0.1312.57PepperFlashpepflashplayer.dll
    > you should have another flash below it, something like: C:WindowsSysWOW64MacromedFlashNPSWF32_11_6_602_168.dll
    – makes sure that remains enabled and select "Always Allow".. KEEP CHROME OPEN FOR NEXT 2 STEPS

    2. Delete this folder: C:UsersUSERNAMEHEREAppDataLocalGoogleChromeUser DataPepperFlash

    3. Delete this folder: C:Program Files (x86)GoogleChromeApplication24.0.1312.57PepperFlash

    4. Restart Chrome, this worked for me and stays removed.

    This worked because you disabled the plugins, and it looks like whenever Chrome starts it recopies the files from the Program Files directory into the Appdata section, if you remove the Program files folder, it will still copy a blank Pepperflash folder back into the appdata, but it will have no contents in it, and thus will not re-enable the plugin.

  71. Unknown

    Thank you!

  72. Jackio

    Did not work for me!

    Adobe Flash Player (2 files) – Version: 11.6.602.171
    Shockwave Flash 11.6 r602
    Name: Shockwave Flash
    Description: Shockwave Flash 11.6 r602
    Version: 11.6.602.171
    Location: C:Documents and SettingsJackiLocal SettingsApplication DataGoogleChromeApplication25.0.1364.97PepperFlashpepflashplayer.dll
    Type: PPAPI (out-of-process)
    Disable
    MIME types:
    MIME type Description File extensions
    application/x-shockwave-flash Shockwave Flash
    .swf
    application/futuresplash FutureSplash Player
    .spl
    Name: Shockwave Flash
    Description: Shockwave Flash 11.6 r602
    Version: 11,6,602,168
    Location: C:WINDOWSsystem32MacromedFlashNPSWF32_11_6_602_168.dll
    Type: NPAPI
    Disable
    MIME types:
    MIME type Description File extensions
    application/x-shockwave-flash Adobe Flash movie
    .swf
    application/futuresplash FutureSplash movie
    .spl

  73. Sheila

    Worked for me! Thanks. πŸ˜€

  74. Anonymous

    Thank you sooo much!

  75. Todd

    thank you, problem solved.

  76. Anonymous

    thank you…bro…your an angel!!!

  77. Anonymous

    THANK YOU!

  78. Anonymous

    YESSS! it worked! THANKS SO MUCH πŸ™‚

  79. Anonymous

    THANKS!

  80. marcusorjames

    You my friend are a frickin genius, so long I have had this issue

  81. GhostbloggerMarie

    Under details, I scrolled to the bottom, nothing called Flash, nothing Macromedia anything and still no youtube sound. Help?
    amyk357@live.com
    Must I give up my Google Chrome?

  82. pablotextoris

    Thanks a lot for this info. Worked like a charm for me! Sound of vids is again back to normal …finaly πŸ˜‰

  83. Queen of the Castle

    Thank you very much – can relax

  84. Anonymous

    finally! the solution!

  85. Unknown

    This worked for me for sometime, but now the problems keep happening, very tempremental. I don't know what to do anymore, and it's not just in Chrome!!!! Help, people, help!!!

  86. Anonymous

    thanks a lot man! really helped

  87. Poop lool

    Well, im sad, because im not sure how to disable the flash player options, thats as far as a I got. :L So i'm confused. How do i disable this?:-/

    Thanks, it would help if you told me how to.

    But so far, Thanks!

    πŸ˜€
    -Poop lool (look at my name haha)

    πŸ™‚

  88. Unknown

    This comment has been removed by the author.

  89. Unknown

    Woo hoo, it worked!…many thanks πŸ™‚

  90. TakeHimToCourt@aol.com

    This guy is a genius. His solution worked for me perfectly. It took only a few seconds to solve the problem, a solution which had eluded me for about one hour. Chrome does not have control over the number of plug-ins installed. My solution worked by disabling one Flash Shockwave and leaving Shockwave enabled. It appears that Chrome does not produce sounds when two Flash players are installed. Can you hear Google engineers?

  91. Dan & fam

    what if I don't have that flashplayer (MacromedFlashNPSWF32_11_3_300_268.dll) to begin with?

  92. Aves

    Just disable the one that has NPSWF32 in it. πŸ™‚

  93. Anonymous

    already attempt this procedure and still no sound while playing youtube

  94. Anonymous

    thank a lot for the solution!!!

  95. cwbullets

    None of this worked for me. Adobe Flash Player – Version: 13.0.0.214

  96. Anonymous

    i have C:Documents and SettingsJackiLocal SettingsApplication DataGoogleChromeApplication25.0.1364.97PepperFlashpepflashplayer.dll but i dont have the other flash which u told to enable now what to do?! pls help

  97. Anonymous

    I too tried ALL the above fixes but finally found what worked for me! I uninstalled google chrome and answered no to "save browsing history". I answered the survey, let them know – no audio, etc. Re-installed Chrome and logged into my Google account – all my bookmarks, passwords were saved, etc. Went to http://www.youtube.com and was blown away by the sound! Good luck – hope this works for you. It just might, because I have never had audio in Chrome.

  98. Anonymous

    This didn't work for me nor did Jeff Dyck's advice. Restarting the computer is the only thing that fixes it.

  99. Answerman

    "Open a new tab and navigate to chrome://plugins/"

    I was able to open a tab, but after half an hour of attempting every possible choice, right click, etc., I could not find 'plugins' or 'chrome/plugins'. I've only been using windows computers since 1998 and have a 145 IQ, so I must be completely hopeless.

Leave A Comment