Add Smilies
Friday, August 03, 2012

How to fix no sound from YouTube in Google Chrome

94 comments
Chrome no sound YouTubeI recently had a problem where I could not get any sound to play when I was watching YouTube videos or playing flash games in Google Chrome. Other browsers, like FireFox and Opera worked fine. The cause of this bug comes from the newest flash player, version 11.3. This bug was really annoying because I had tried many solutions, but none had worked until I tried disabling all, but one of the flash player plugins.

I noticed that I had 3 different flash player plugins running in Google Chrome and thought that 1 should be enough. So I decided to disable 2 of the flash player plugins and leave one running and it worked! I had fixed my issue with no sound from Google Chrome when watching YouTube videos.

The Solution

  1. Open a new tab and navigate to chrome://plugins/
  2. At the top right, click on +Details
  3. Scroll down until you see Flash
  4. Disable all the flash player plugins, but the one with the directory Macromed\Flash\NPSWF32_11_3_300_268.dll
  5. Open a new tab and go to YouTube
  6. Watch a video and you should be able to hear sound
  7. Enjoy
Tired of having to search Google for problems like these and clicking through many links just to find the solution? Then go to http://www.ifixwiki.com/, a community-run website dedicated to providing solutions to problems, issues, and errors that occur in everyday situations from software like Windows 7 to hardware like a bicycle.

94 Responses so far

  1. Anonymous says:

    Thanks, this worked for me.

  2. Anonymous says:

    Thank you so much!

  3. Anonymous says:

    You're a legend bro!

  4. Anonymous says:

    Thank you so much, this really helped me a lot.

  5. Anonymous says:

    So after all of this I can't seem to clear my browsing history... Anyone else have the same problem? Would it even make sense for this to be the source of that issue?

    (But thanks again, for the sound fix.)

  6. Anonymous says:

    What a bizarre problem. Google chrome should get out of the browser market

  7. Anonymous says:

    Like a charm! ;))

    Second time You-Tube had no sound! ~x(


    But before-it was in ALL the browsers--:]and then I had to delete some weird file and it worked. THIS time mute was ONLY in Chrome and your solution worked immediately. Awesome!Thanks!

  8. Anonymous says:

    recently we put windows 7. This fixed my problem^^ happy-desu!! Thank u :)

  9. Anonymous says:

    thanks!!

  10. Anonymous says:

    It says (17) on top of my Flash tab. Which means there's 17 files in it?.. but I clicked disable but there's 2 disable buttons?... I click one and the other disables anyway..

    Meh I've tried at least 12 different ways.. computers p%$£ me off.. why would a browser randomly do this?.. Google are money hungry sell outs.... I'm not using crappy chrome any more.

  11. Anonymous says:

    Fixed it...sound disapeared after updating flash...

    Thank you!

  12. Anonymous says:

    TY MAN! i had to disable the opposite flash plugin 8-}

  13. Anonymous says:

    henyo!!

  14. Giwrgos says:

    ty man...really helpful!!!!

    love you.

  15. Moimemme says:

    Just change sound settings to stereo or 2 speakers.

  16. Anonymous says:

    THANKSSSSSSSSSSSSSSSSSSSSS !!!!!!!

  17. Anonymous says:

    THANK YOU VERY MUCH!!!!!(((((: IT WORKED!!!!(((:

  18. Nice one that was really annoying me, I had to disable

    Application\23.0.1271.64\PepperFlash\pepflashplayer.dll

    but it was your post that got me there. Again thank you. :D

  19. athena says:

    still not working for me huhu

  20. Anonymous says:

    thanks mate!!

  21. Anonymous says:

    great advices there

    did the trick for me

    thank you

  22. Anonymous says:

    Really really thanks man. Now i can watch youtube again :)) !

  23. Anonymous says:

    Hey! All other solutions haven't worked to mine. It definitely works! You're so geneous! - hieonn

  24. thanks!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :P

  25. Anonymous says:

    Works perfectly, thank you

  26. This comment has been removed by the author.
  27. Yiota says:

    Thank you! Thank ;)

  28. Anonymous says:

    THANK YOU SO VERY MUCH!

  29. Anonymous says:

    This did the trick after searching for 2 days. Thanks so much!

  30. Worked perfectly, thanks bunches C:

  31. It worked :) Thanks a ton

  32. Anonymous says:

    Thanks

  33. Anonymous says:

    Thanks. Working for me too.

  34. Anonymous says:

    ythanks

  35. Anonymous says:

    Thank you, worked like a charm!

  36. Anonymous says:

    UGH THIS STILL DOES NOT WORK!!!!! I have tried EVERYTHING!!

  37. Anonymous says:

    I don't understand, when I disable that and then go to youtube it says I need to upgrade my flash player!

  38. Anonymous says:

    Thank You Very Much or as in my language says 'Terima Kasih' because you have been very helpful. Bless u

  39. Anonymous says:

    Thanks a lot it worked.

  40. Anonymous says:

    IT WORKED!Thanks :)

  41. coiso says:

    ok, it worked but... why the hell did this happen in the first place?

  42. DannyR says:

    Finally fixed. Thank you so much. Was so annoying...

  43. Rengga says:

    Thank you :D

  44. christna says:

    i was having a problem in chrome on my toshiba laptop where embedded videos had sound until i plugged in my logitech headset, then i would lose sound and the sound would stay gone when i unplugged my headset. the sound continued to work as expected in firefox and ie.

    i followed your instructions and it worked perfectly! i just wanted to add detail so that other googlers can find it. it took me a LOT of searching to get to this page!

  45. Anonymous says:

    Thankyou, you saved my life.

    No music - No life.

  46. Anonymous says:

    Thank you!

  47. thank you so much man ! :)

  48. this is says:

    Try: Update flash via Firefox or other browser.
    Check shockwave updates/

    Also ensure Stereo in volume mixer and low sample rate.

  49. Anonymous says:

    Thank you so much!!!! :D

  50. Anonymous says:

    Thanks this fixed mine! :D

  51. Annetta says:

    Thanks so very much!!!

  52. Roars says:

    THANK YOU! was wondering why media player could play sound but youtube didn't! :-)

  53. antonis73 says:

    The best, easiest and simplest fix. Thank you!

  54. antonis73 says:

    The best, easiest and simplest fix. Thank you!

  55. Marlon says:

    I came across this article on a previous search, but didn't read it more carefully till yesterday. Thank you for the excellent tip. Chrome should be smarter and not load multiple versions!

  56. Anonymous says:

    Thanks a lot man, this frustration is finally gone!

  57. Anonymous says:

    Thanks a lot buddy.. U save my day :D

  58. Anonymous says:

    Thanks! Now i can hear sounds of videos what are not on my playlist. So i got new problem now, i can´t hear sounds on any video what is added on my playlist :-/ On firefox they are fine..pff.

  59. Anonymous says:

    You saved a monitor from my fist today.

  60. Daniel says:

    awesome. simply works.

  61. Anonymous says:

    I have tried at least 5 different solution, but this worked. Thanks!

  62. Anonymous says:

    this still didnt work for me...still cant hear anything!!!wtf

  63. ed robles says:

    OUTSTANDING!! Your Intel fixed my problem...good look

  64. Jeff Dyck says:

    Nice! Worked for me. Thanks.

  65. Anonymous says:

    Thank you so much. I spent 2 hours looking for a solution. My brain is fried.
    After restarting Google Chrome, the plugin re-enables itself.
    Please follow these steps to resolve it permanently.

    http://productforums.google.com/forum/#!topic/chrome/ufkQg9N-L0s

    This solution worked for me. I did all of the following steps in this order.

    1. Open up Google Chrome, go to settings > advanced settings > content settings > under plugins - disable individual plugins > expand details in upper right > DISABLE shockwave flash with this location only C:\Program Files (x86)\Google\Chrome\Application\24.0.1312.57\PepperFlash\pepflashplayer.dll
    > you should have another flash below it, something like: C:\Windows\SysWOW64\Macromed\Flash\NPSWF32_11_6_602_168.dll
    - makes sure that remains enabled and select "Always Allow".. KEEP CHROME OPEN FOR NEXT 2 STEPS

    2. Delete this folder: C:\Users\USERNAMEHERE\AppData\Local\Google\Chrome\User Data\PepperFlash

    3. Delete this folder: C:\Program Files (x86)\Google\Chrome\Application\24.0.1312.57\PepperFlash

    4. Restart Chrome, this worked for me and stays removed.

    This worked because you disabled the plugins, and it looks like whenever Chrome starts it recopies the files from the Program Files directory into the Appdata section, if you remove the Program files folder, it will still copy a blank Pepperflash folder back into the appdata, but it will have no contents in it, and thus will not re-enable the plugin.

  66. Did not work for me!


    Adobe Flash Player (2 files) - Version: 11.6.602.171
    Shockwave Flash 11.6 r602
    Name: Shockwave Flash
    Description: Shockwave Flash 11.6 r602
    Version: 11.6.602.171
    Location: C:\Documents and Settings\Jacki\Local Settings\Application Data\Google\Chrome\Application\25.0.1364.97\PepperFlash\pepflashplayer.dll
    Type: PPAPI (out-of-process)
    Disable
    MIME types:
    MIME type Description File extensions
    application/x-shockwave-flash Shockwave Flash
    .swf
    application/futuresplash FutureSplash Player
    .spl
    Name: Shockwave Flash
    Description: Shockwave Flash 11.6 r602
    Version: 11,6,602,168
    Location: C:\WINDOWS\system32\Macromed\Flash\NPSWF32_11_6_602_168.dll
    Type: NPAPI
    Disable
    MIME types:
    MIME type Description File extensions
    application/x-shockwave-flash Adobe Flash movie
    .swf
    application/futuresplash FutureSplash movie
    .spl

  67. Sheila says:

    Worked for me! Thanks. :D

  68. Anonymous says:

    Thank you sooo much!

  69. Todd says:

    thank you, problem solved.

  70. Anonymous says:

    thank you...bro...your an angel!!!

  71. Anonymous says:

    THANK YOU!

  72. Anonymous says:

    YESSS! it worked! THANKS SO MUCH :)

  73. Anonymous says:

    THANKS!

  74. You my friend are a frickin genius, so long I have had this issue

  75. Under details, I scrolled to the bottom, nothing called Flash, nothing Macromedia anything and still no youtube sound. Help?
    amyk357@live.com
    Must I give up my Google Chrome?

  76. Thanks a lot for this info. Worked like a charm for me! Sound of vids is again back to normal ...finaly ;)

  77. Thank you very much - can relax

  78. Anonymous says:

    finally! the solution!

  79. Unknown says:

    This worked for me for sometime, but now the problems keep happening, very tempremental. I don't know what to do anymore, and it's not just in Chrome!!!! Help, people, help!!!

  80. Anonymous says:

    thanks a lot man! really helped

  81. Poop lool says:

    Well, im sad, because im not sure how to disable the flash player options, thats as far as a I got. :L So i'm confused. How do i disable this?:-/

    Thanks, it would help if you told me how to.

    But so far, Thanks!

    :D
    -Poop lool (look at my name haha)

    :)

  82. Woo hoo, it worked!...many thanks :)

  83. This guy is a genius. His solution worked for me perfectly. It took only a few seconds to solve the problem, a solution which had eluded me for about one hour. Chrome does not have control over the number of plug-ins installed. My solution worked by disabling one Flash Shockwave and leaving Shockwave enabled. It appears that Chrome does not produce sounds when two Flash players are installed. Can you hear Google engineers?

  84. Dan & fam says:

    what if I don't have that flashplayer (Macromed\Flash\NPSWF32_11_3_300_268.dll) to begin with?

  85. Aves says:

    Just disable the one that has NPSWF32 in it. :)

  86. Anonymous says:

    already attempt this procedure and still no sound while playing youtube

  87. Anonymous says:

    thank a lot for the solution!!!

:)) ;)) ;;) :D ;) :p :(( :) :( :X =(( :-o :-/ :-* :| 8-} :)] ~x( :-t b-( :-L x( =))

Leave a Reply